您现在的位置是:首页 > 运维网络杂文

OSPF虚拟链路配置方法

阿龙2022-05-21【网络杂文】人已围观





以上图中有4个区域,分别为AREA0-3,在不配VLINK的情况下,AREA3是无法拼通前三个,链路在AREA2之间产生。

实现如下:
AR1
interface GigabitEthernet0/0/0
 ip address 192.168.10.1 255.255.255.0 
interface GigabitEthernet0/0/1
ospf 1 router-id 1.1.1.1 
 area 0.0.0.1 
  network 192.168.10.0 0.0.0.255 
AR2
interface GigabitEthernet0/0/0
 ip address 192.168.10.2 255.255.255.0 
interface GigabitEthernet0/0/1
 ip address 192.168.20.1 255.255.255.0 
ospf 1 router-id 2.2.2.2 
 area 0.0.0.0 
  network 192.168.20.0 0.0.0.255 
 area 0.0.0.1 
  network 192.168.10.0 0.0.0.255 
AR3
interface GigabitEthernet0/0/0
 ip address 192.168.20.2 255.255.255.0 
interface GigabitEthernet0/0/1
 ip address 192.168.30.1 255.255.255.0 
ospf 1 router-id 3.3.3.3 
 area 0.0.0.0 
  network 192.168.20.0 0.0.0.255 
 area 0.0.0.2 
  network 192.168.30.0 0.0.0.255 
  vlink-peer 4.4.4.4
AR4
interface GigabitEthernet0/0/0
 ip address 192.168.30.2 255.255.255.0 
interface GigabitEthernet0/0/1
 ip address 10.1.1.1 255.255.255.0 
ospf 1 router-id 4.4.4.4 
 area 0.0.0.2 
  network 192.168.30.0 0.0.0.255 
  vlink-peer 3.3.3.3
 area 0.0.0.3 
  network 10.1.1.0 0.0.0.255 
AR5
interface GigabitEthernet0/0/0
 ip address 10.1.1.2 255.255.255.0 
interface GigabitEthernet0/0/1
ospf 1 router-id 5.5.5.5 
 area 0.0.0.3 
  network 10.1.1.0 0.0.0.255 
 

Tags:OSPF   vlink-

很赞哦! ()